最专业的FPGA ZYNQ论坛--黑金动力社区

 找回密码
 注册
查看: 24166|回复: 62

大家要注意,FPGA的JTAG口很脆弱!!!

  [复制链接]
avic 发表于 2010-11-25 22:57:29 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
最近我的FPGA罢工了,而且是部分罢工,FPGA的JTAG口不能下载程序,这种事情不是第一次了,在我的项目中也出现过。而且出现的形式也极其相似,很离奇。前一天晚上用的还好好的,第二天就不行了,真是让人郁闷的不行。为了继续让他工作我换了好几个usb-blaster,可一点都没见成效。难道JTAG口真的坏了。上网百度了一下,结果发下了下面的结论,原文如下:
根据ALTERA官方FAE(现场应用工程师)的强烈建议,请注意不要随意带电插拔JTAG下载接口,否则会损坏FPGA芯片的JTAG口信号管脚。
现象:
在排除了下载线的问题后,还是不能访问FPGA的JTAG口,那么很有可能你的FPGA芯片的JTAG口已经损坏。此时请用万用表检查TCK,TMS,TDO和Tdi是否和GND短路,如果任何一个信号对地短路则表示JTAG信号管脚已经损坏。
原因分析:
我们经常为了方便,随意插拔JTAG下载口,在多数情况下不会发生任何问题。仍然有很小的概率因为热插拔而产生的JTAG口的静电和浪涌,最终导致FPGA管脚的击穿。
有人怀疑是否是D版的USB Blaster或者ByteBlasterII设计简化,去处了保护电路导致的。但事实证明原装的USB Blaster也会发生同样的问题。
我们怀疑是否是ALTERA的低端芯片为了降低成本,FPGA的IO单元没有加二极管钳位保护电路。
我们的建议:
请大家尽量按照以下步骤进行板子和下载线的上电、下电顺序:
上电顺序:
1.在FPGA板子断电的情况下,插上JTAG下载线接口
2.插上USB Blaster或者ByteBlasterII的电缆
3.插上FPGA板子的电源
下电顺序:
1. 断开FPGA板子的电源        
2.断开USB Blaster或者ByteBlasterII的电缆
3.断开JTAG下载线接口
虽然上面的步骤有点繁琐,但是为了保证芯片不被损坏,希望大家按照上面的步骤来操作。

      我就纳闷了,难道FPGA的JTAG口真的那么脆弱?我按照上述次方法,结果发现,TCK真的跟GND短路了,真是郁闷至极啊。只能动手术了,换了片子以后,JTAG口真的好了。我就想如何才能避免这种悲剧再次发生呢?自己加入一些保护电路可以么?百度了一下也没什么结果,为了避免再次罢工现象发生,我决定还是先按上述方法操作吧,在这里也给大家提个醒,尽量不要带电热插拔,以免步我的后尘。
 楼主| avic 发表于 2010-11-25 23:29:46 | 显示全部楼层
这个帖子是很久之前的帖子,发出来是提醒大家,一定要注意下,不要带电插拔BLASTER
akuei2 发表于 2010-11-26 07:46:23 | 显示全部楼层
呵呵呵!会注意的~
xiaozhong 发表于 2010-11-26 22:25:36 | 显示全部楼层
很好
zgxcom123 发表于 2010-11-27 22:38:19 | 显示全部楼层
仿真器连接电脑,板子断电,这样可以插拔么?
zgxcom123 发表于 2010-11-27 22:40:11 | 显示全部楼层
另外还想请教一下,如果在打开NIOS2IDE之后再连接仿真器,软件可以识别到么
sibq80 发表于 2010-12-1 00:09:51 | 显示全部楼层
那可要小心了!否则100块就没有了!
bluesusu 发表于 2010-12-1 01:00:24 | 显示全部楼层
请问一下如何人为的方便的使jtag损坏………………
鑫海宝贝 发表于 2010-12-5 12:38:53 | 显示全部楼层
恩是的注意了!!!
fuyuwang 发表于 2010-12-5 13:55:25 | 显示全部楼层
恩,千万不要杯具了。
hardware_hh 发表于 2010-12-11 15:13:46 | 显示全部楼层
谢谢楼主
zhangxin0804 发表于 2011-1-3 11:30:55 | 显示全部楼层
学习了,谢谢楼主
mierbufan 发表于 2011-1-20 22:31:53 | 显示全部楼层
一直带电插拔,从未出问题。。。
wg305050912 发表于 2011-2-13 16:45:06 | 显示全部楼层
很好,很强大
zlulu2006 发表于 2011-2-19 15:01:30 | 显示全部楼层
不能带点插拔,明白了
leikeylianglei 发表于 2011-3-7 21:56:55 | 显示全部楼层
出了一身的冷汗 我今天还带电拔了好几次呢  没有早一点看到 怪我自己啊
gaoyukun 发表于 2011-4-5 10:54:40 | 显示全部楼层
嘻嘻,在用DE1,肯定是先断电~因为供电,blaster是一根USB线:)
supercommando 发表于 2011-4-6 16:35:12 | 显示全部楼层
恩,已经注意了,谢谢楼主!
savager007 发表于 2011-5-9 13:55:17 | 显示全部楼层
我也遇上过一次
heyoujing 发表于 2011-9-25 20:44:56 | 显示全部楼层
以前碰到过,FPGA和usb-blaster都出现损坏的情况
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|@2009-2016 芯驿电子科技(上海)有限公司|小黑屋|手机版|Archiver|黑金动力社区 ( 沪ICP备11013590沪公网安备 31011702000003号 举报投诉电话:15300558155

GMT+8, 2019-3-19 06:31 , Processed in 0.087674 second(s), 18 queries , Gzip On.

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表